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Legal Information
The Schneider Electric brand and any trademarks of Schneider Electric SE and its
subsidiaries referred to in this guide are the property of Schneider Electric SE or its
subsidiaries. All other brands may be trademarks of their respective owners.

This guide and its content are protected under applicable copyright laws and
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transmitted in any form or by any means (electronic, mechanical, photocopying,
recording, or otherwise), for any purpose, without the prior written permission of
Schneider Electric.
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is" basis. Schneider Electric products and equipment should be installed, operated,
serviced, and maintained only by qualified personnel.

As standards, specifications, and designs change from time to time, information
contained in this guide may be subject to change without notice.

To the extent permitted by applicable law, no responsibility or liability is assumed by
Schneider Electric and its subsidiaries for any errors or omissions in the informational
content of this material or consequences arising out of or resulting from the use of the
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Safety Information

Important Information
Read these instructions carefully, and look at the equipment to become familiar
with the device before trying to install, operate, service, or maintain it. The
following special messages may appear throughout this documentation or on the
equipment to warn of potential hazards or to call attention to information that
clarifies or simplifies a procedure.

Please Note

Electrical equipment should be installed, operated, serviced, and maintained only
by qualified personnel. No responsibility is assumed by Schneider Electric for any
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction
and operation of electrical equipment and its installation, and has received safety
training to recognize and avoid the hazards involved.

The addition of this symbol to a “Danger” or “Warning” safety label indicates that an 
electrical hazard exists which will result in personal injury if the instructions are not 
followed.

This is the safety alert symbol. It is used to alert you to potential personal injury 
hazards. Obey all safety messages that follow this symbol to avoid possible injury or 
death.

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious 
injury.

! DANGER

WARNING indicates a hazardous situation which, if not avoided, could result in death or 
serious injury.

WARNING!

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or 
moderate injury.

CAUTION!

NOTICE is used to address practices not related to physical injury.

NOTICE
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About the Book

Document Scope
This document provides the steps required in EcoStruxure™ Control Expert
Classic software to create a project with a TeSys™ island and a logic/motion
controller using the Modbus TCP protocol.

This document also provides the details about:
• Integrating the TeSys island into the EcoStruxure Control Expert Classic

project.
• Accessing the TeSys island DTM (Device Type Manager) via EcoStruxure

Control Expert Classic software for configuring the TeSys island modules and
processes by using TeSys avatars.

• Using the function blocks of the TeSys island library that is available in
EcoStruxure Control Expert Classic software for developing applications and
to control TeSys avatar modules.

It is recommended that before using this document, the user must have
knowledge on:

• Information on functionality, structure, and configuration of the TeSys island
• Information on functionality, structure, and configuration of the controller

Validity Note
This guide is only valid for:

• EcoStruxure Control Expert Classic software v15.0 SP1 – Classic
• PLC Modicon M580

Online Information
The information contained in this guide is likely to be updated at any time.
Schneider Electric strongly recommends that you have the most recent and up-to-
date version available on www.se.com/ww/en/download/.

The technical characteristics of the devices described in the present document
also appear online. To access the information online, go to the Schneider Electric
home page.

Related Documents

Title of documentation Reference number
TeSys island – System Guide 8536IB1901EN

TeSys island DTM Library Online Help Available with the installer

Modicon M580 – Hardware Reference Manual EIO0000001578

EcoStruxure Control Expert – TeSys island Library Control User Guide EIO0000004519
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Terminology Derived from Standards
The technical terms, terminology, symbols and the corresponding descriptions in
this manual, or that appear in or on the products themselves, are generally
derived from the terms or definitions of international standards.

In the area of functional safety systems, drives and general automation, this may
include, but is not limited to, terms such as safety, safety function, safe state, fault,
fault reset, malfunction, failure, error, error message, dangerous, and so on.

The standards included are:

Standard Description

IEC 61131-2:2007 Programmable controllers, part 2: Equipment requirements and tests.

ISO 13849-1:2015 Safety of machinery: Safety related parts of control systems.

General principles for design.

EN 61496-1:2013 Safety of machinery: Electro-sensitive protective equipment.

Part 1: General requirements and tests.

ISO 12100:2010 Safety of machinery - General principles for design - Risk assessment and risk
reduction

EN 60204-1:2006 Safety of machinery - Electrical equipment of machines - Part 1: General
requirements

ISO 14119:2013 Safety of machinery - Interlocking devices associated with guards - Principles for
design and selection

ISO 13850:2015 Safety of machinery - Emergency stop - Principles for design

IEC 62061:2015 Safety of machinery - Functional safety of safety-related electrical, electronic, and
electronic programmable control systems

IEC 61508-1:2010 Functional safety of electrical/electronic/programmable electronic safetyrelated
systems: General requirements.

IEC 61508-2:2010 Functional safety of electrical/electronic/programmable electronic safetyrelated
systems: Requirements for electrical/electronic/programmable electronic safety-
related systems.

IEC 61508-3:2010 Functional safety of electrical/electronic/programmable electronic safetyrelated
systems: Software requirements.

IEC 61784-3:2016 Industrial communication networks - Profiles - Part 3: Functional safety fieldbuses -
General rules and profile definitions.

2006/42/EC Machinery Directive

2014/30/EU Electromagnetic Compatibility Directive

2014/35/EU Low Voltage Directive

In addition, terms used in the present document may tangentially be used as they
are derived from other standards such as:

Standard Description

IEC 60034 series Rotating electrical machines

IEC 61800 series Adjustable speed electrical power drive systems

IEC 61158 series Digital data communications for measurement and control – Fieldbus for use in
industrial control systems
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Finally, the term zone of operation may be used in conjunction with the description
of specific hazards, and is defined as it is for a hazard zone or danger zone in the
Machinery Directive (2006/42/EC) and ISO 12100:2010.

NOTE: The aforementioned standards may or may not apply to the specific
products cited in the present documentation. For more information concerning
the individual standards applicable to the products described herein, see the
characteristics tables for those product references.

Product Related Information

WARNING
LOSS OF CONTROL
• The designer of any control scheme must consider the potential failure

modes of control paths and, for certain critical control functions, provide a
means to achieve a safe state during and after a path failure. Examples of
critical control functions are emergency stop and overtravel stop, power
outage and restart.

• Separate or redundant control paths must be provided for critical control
functions.

• System control paths may include communication links. Consideration must
be given to the implications of unanticipated transmission delays or failures
of the link.

• Observe all accident prevention regulations and local safety guidelines.1

• Each implementation of this equipment must be individually and thoroughly
tested for proper operation before being placed into service.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Only use software approved by Schneider Electric for use with this

equipment.
• Update your application program every time you change the physical

hardware configuration.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

8 DOCA0236EN-00
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Before You Begin
Do not use this product on machinery lacking effective point-of-operation
guarding. Lack of effective point-of-operation guarding on a machine can result in
serious injury to the operator of that machine.

WARNING
UNGUARDED EQUIPMENT
• Do not use this software and related automation equipment on packaging

equipment which does not have point-of-operation protection.
• Do not reach into machinery during operation.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

This automation equipment and related software is used to control a variety of
industrial processes. The type or model of automation equipment suitable for each
application will vary depending on factors such as the control function required,
degree of protection required, production methods, unusual conditions,
government regulations, etc. In some applications, more than one processor may
be required, as when backup redundancy is needed.

Only the user can be aware of all the conditions and factors present during setup,
operation and maintenance of the machine; therefore, only the user can determine
the automation equipment and the related safeties and interlocks which can be
properly used. When selecting automation and control equipment and related
software for a particular application, the user should refer to the applicable local
and national standards and regulations. The Accident Prevention Manual
(nationally recognized in the United States of America) also provides much useful
information.

In some applications, such as packaging machinery, additional operator protection
such as point-of-operation guarding must be provided. This is necessary if the
operator's hands and other parts of the body are free to enter the pinch point area
and serious injury can occur. Software products cannot protect an operator from
injury. For this reason the software cannot be substituted for or take the place of
point-of-operation protection.

Ensure that appropriate safeties and interlocks related to point-of-operation
protection have been installed and are operational before placing the equipment
into service. All interlocks and safeties related to point-of-operation protection
must be coordinated with the related automation equipment and software
programming.

NOTE: Coordination of safeties and mechanical/electrical interlocks for point-
of-operation protection is outside the scope of the Function Block Library,
System User Guide, or other implementation referenced in this
documentation.
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Start-Up and Test
Before using electrical control and automation equipment for regular operation
after installation, the system should be given a start up test by qualified personnel
to verify correct operation of the equipment. It is important that arrangements for
such a check be made and that enough time is allowed to perform complete and
satisfactory testing.

WARNING
EQUIPMENT OPERATION HAZARD
• Verify that all installation and set up procedures have been completed.
• Before operational tests are performed, remove all blocks or other temporary

holding means used for shipment from all component devices.
• Remove tools, meters and debris from equipment.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Follow all start up tests recommended in the equipment documentation. Store all
equipment documentation for future references.

Software testing must be done in both simulated and real environments.

Verify that the completed system is free from all short circuits and grounds, except
those grounds installed according to local regulations (according to the National
Electrical Code in the U.S.A, for instance). If high-potential voltage testing is
necessary, follow recommendations in equipment documentation to help prevent
from accidental equipment damage.

Before energizing equipment:
• Remove tools, meters and debris from equipment.
• Close the equipment enclosure door.
• Remove ground from incoming power lines.
• Perform all start-up tests recommended by the manufacturer.

Operation and Adjustments
The following precautions are from the NEMA Standards Publication ICS 7.1-1995
(English version prevails):

• Regardless of the care exercised in the design and manufacture of equipment
or in the selection and ratings of components, there are hazards that can be
encountered if such equipment is improperly operated.

• It is sometimes possible to misadjust the equipment and thus produce
unsatisfactory or unsafe operation. Always use the manufacturer’s
instructions as a guide for functional adjustments. Personnel who have
access to these adjustments should be familiar with the equipment
manufacturer’s instructions and the machinery used with the electrical
equipment.

• Only those operational adjustments actually required by the operator should
be accessible to the operator. Access to other controls should be restricted to
help prevent unauthorized changes in operating characteristics.
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Introduction to TeSys island

TeSys Master Range
TeSys is an innovative motor control and management solution from the global
market leader. TeSys offers connected, efficient products and solutions for
switching and protection of motors and electrical loads in compliance with all
major global electrical standards.

Overview
TeSys island delivers a connected and customized system for the direct control
and management of low-voltage loads. The island optimizes availability of the
physical modules with embedded pre-alarming management capabilities.

TeSys island targets performance and high-performance machines with
automation architectures based on high-speed networks connecting devices to a
PLC. Machinery operating at high production rates must avoid unplanned
production downtime, which can be extremely costly. TeSys island helps to reduce
unplanned downtime with predictive maintenance so that repairs can be
completed during a scheduled maintenance window.

TeSys island is fully integrated into the PLC programming environment using
digital objects. TeSys island is fully integrated into the EcoStruxure portfolio that
combines products and software packages into automation solutions for OEMs
and machine builders. The system also supports integration into third-party PLCs.

DOCA0236EN-00 11
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TeSys island Concept
TeSys island describes an open, modular distributed input/output system
comprising different modules mounted on a DIN rail backplane.

A Bus coupler

B Analog input/output module

C Digital input/output module

D Voltage interface module

E Standard starter

F SIL (Safety Integrity Level) starter

G SIL interface module

H Power interface module

The TeSys island device acts as a node in a fieldbus network. The bus coupler is
the core module of the device. The bus coupler provides internal communication
with the TeSys island modules via ribbon cables and external communication via
Modbus TCP protocol.

For more information, refer to the TeSys island System Guide.

System Requirements
The following components are required for communication via EtherNet/IP or
Modbus TCP.

Component Type and Version

EcoStruxure Control Expert Classic software Classic V15.0 SP1

PSx DTM Library version 3.14.54

Schneider_Electric_TeSys_island_DTM_Library version 2.2.2 or later

Controller BMEP58•••• logic controller
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Integrating TeSys island into EcoStruxure Control
Expert Classic Project

Creating a Project
NOTE: Before creating a new project, you must know the type of PLC model
and PLC backplane required to integrate into the project.

Perform the below steps to create a project:

Step Action

1 Open EcoStruxure Contol Expert Classic software.

2 Click File > New.

Result: List of PLCs is displayed on the screen.

3 Select a PLC Modicon M580 according to the hardware that will be used for the project.
1. In the PLC window, click Modicon M580.
2. In the Rack window, expand Modicon M580 local drop and select a rack.
3. Click OK.

Result:
a. A processing command window appears. Wait for some time to complete the processing

of the configuration files.
b. When the processing of files is completed, the Security enforcement window is

displayed on the screen.

DOCA0236EN-00 13
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Integrating TeSys island into EcoStruxure Control Expert

Classic Project

Step Action

4 To manage a password, perform one of the following steps as required:
• Create a new password for the project and click OK.
• Click Cancel if password is not required.
Result: The structure of the project is created and displayed in the Project Browser window.

5 Double-click the Configuration folder in the Structural view.

Result: The physical view of the device configuration is displayed on the screen.

14 DOCA0236EN-00
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Adding TeSys island to the Project
Perform the below steps to add TeSys island to the project:

Step Action

1 Click Tools > DTM Browser.

2 Right-click on the CPU name in the DTM Browser window and select ADD.

Result: The ADD window is displayed on the screen.

3 In the Protocol drop-down menu, select Modbus over TCP.
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Integrating TeSys island into EcoStruxure Control Expert

Classic Project

Step Action

4 Select TeSys island device and click Add DTM.

Result: The device properties window is displayed on the screen.

5 In the Properties of device window, change the name of the device if required and click OK.
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Configuring the IPAddress of the CPU
Perform the below steps to configure the IP address of the CPU:

Step Action

1 Double-click the Configuration folder in the Project Browser window.

Result: The physical view of the device configuration is displayed on the screen.

2 Double-click the communication connectors of the PLC on the PLC bus window.

Result: The communication settings window of the PLC is displayed on the screen.

3 Click Security menu and perform one of the following steps as required:
• Click Enforce Security to enable or disable the services.
• Click Unlock Security to enable all services.

DOCA0236EN-00 17
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Integrating TeSys island into EcoStruxure Control Expert

Classic Project

Step Action

4 Click IP Configuration menu and set the IP address of the CPU according to the network.

Note: The IP address A has to be different than the Main IP address.

5
Click the Validate icon ( ) on the toolbar.
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Configuring the IPAddress of the TeSys island
Perform the below steps to configure the IP address of the TeSys island:

Step Action

1 Double-click the CPU in the DTM Browser window.

Result: The device configuration window is displayed on the screen.

2 Select TeSys island device > Address Setting menu, and configure the IP address of the TeSys
island.

3 Click Apply.

4

Click the Build icon ( ) on the toolbar.

DOCA0236EN-00 19
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Integrating TeSys island into EcoStruxure Control Expert

Classic Project

Uploading TeSys island Project to PLC
Perform the below steps to upload the TeSys island project to PLC:

Step Action

1 Establish the connection between the PC and PLC by performing one of the following steps:
• Connect to the PLC by using the IP address.

• Connect the USB ground cable (BMXXCAUSBH018) between the PC and the front panel of the
PLC M580.

2
Click the Connect icon ( ) on the toolbar.

20 DOCA0236EN-00



Integrating TeSys island into EcoStruxure Control Expert
Classic Project TeSys island – Digital Motor Management Solution

Step Action

3
Click the Download icon ( ) on the toolbar.

Result: The Transfer Project to PLC window is displayed on the screen.

4 Click Transfer.

Result: The TeSys island project is uploaded to the PLC.

5 Double-click the CPU in the DTM Browser window.

Result: The communication window is displayed on the screen.

6 Select Channel Properties > IPAddress Source (PC), and click OK.

7 Right-click on the CPU name in the DTM Browser window and select Connect.
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Integrating TeSys island into EcoStruxure Control Expert

Classic Project

Step Action

8 Right-click on the TeSys island device in the DTM Browser window and select Connect.

9 Based on the specific requirement, you can choose one of the following steps to configure the TeSys
island:

• If the TeSys island has already been configured and the user does not want to upload a new
configuration, right-click on the TeSys island device in the DTM Browser window and select Load
data from device.

• If the TeSys island has not been configured and the user wants to upload a new configuration,
perform one of the following steps as required:
◦ Double-click on the TeSys island device in the DTM Browser window and configure the

device.

◦ Right-click on the TeSys island device in the DTM Browser window, and click Device menu >
Additional functions > Import > Import TeSys island Configurator Format to import the
configuration files.
Result: The new configuration is imported into the software.
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Step Action

10 Double-click the TeSys island device in the DTM Browser window, and select Store data to device.

DOCA0236EN-00 23



TeSys island – Digital Motor Management Solution
Integrating TeSys island into EcoStruxure Control Expert

Classic Project

Uploading TeSys island Project to PLC via Ethernet Cable
Perform the below steps to upload the TeSys island project to PLC via Ethernet
cable:

Step Action

1 Click PLC > Set Address.

Result: The Set Address window is displayed on the screen.

2 Select the IP address of the PLC. Select the Media as TCPIP and click OK.

3
Click the Connect icon ( ) on the toolbar.

Result: TeSys island is integrated into the project and connected to the PLC Modicon M580 with
EcoStruxure Control Expert Classic software.
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Using the TeSys island Library for Developing
Applications

Overview
The TeSys island library is added to the Types Library Manager in the
EcoStruxure Control Expert Classic software. The library manager provides
function blocks to support in developing applications and to control TeSys avatars.

Installing Function Blocks of TeSys island Library
Perform the below steps to install the function blocks of TeSys island library:

Step Action

1 Download the latest EcoStruxure Control Expert 2021 – TeSys island Library.zip file from Schneider
Electric Industry End Users and SI Campus.

2 Extract the zip file in the local hard disk.

3 Click Start > EcoStruxure Control Expert Classic > Types library update.

Result: Types library update window is displayed on the screen.

4 Click Browse button.

5 Browse the location of the extracted zip folder, select FAMILY.DSC file, and click Open.
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Step Action

6 Click Install family.

Result: The installation of the library file starts.

7 On successful installation of a family file, a message appears on the screen. Click OK.

8 Open EcoStruxure Control Expert Classic software. Click Tools > Types Library Manager.

Result: TeSys island Library 2021 is displayed under Libset V15.0 or later.

26 DOCA0236EN-00
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Configuring Project Settings
Perform the below steps to configure the project settings:

Step Action

1 Open the generated .stu or .xref file in EcoStruxure Control Expert Classic software.

2 Click Tools > Project Settings.

Result: Project Settings window is displayed on the screen.

3 Click Variables and select the Allow dynamic arrays (ANY_ARRAY_XXX) check box to avoid the
detected error E1208 usage of dynamic arrays is disabled reported when compiling the project.

4 Clear the Force references initialization check box.

5 Click Languages > Common and select the Allow multi assignment [a=b=c] {ST/LD} check box
to avoid the detected error E1203 usage of multi assignment statements is disabled reported
when compiling the project.
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Using Function Blocks for Developing Application
Perform the below steps to use the function block for developing the application in
EcoStruxure Control Expert Classic software:

Step Action

1 In Project Browser window, click Programs >Tasks > MAST > Logic.

2 Right-click on the Logic folder and select New Section.

Result: The New Section window is displayed on the screen.

3 Enter a new name to the function block. Select language FBD and click OK.

Result: The configuration zone window is displayed on the screen.

4 Right-click on the configuration zone and select FFB Input Assistant.

Result: Function Input Assistant window is displayed on the screen.
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Step Action

5 Click the Browse button located next to Function Input Assistant screen.

Result: FFB Type Selection window is displayed on the screen.

6 On FFB Type Selection screen, select <Libset V15.0> > TeSys island Library 2021 and then
select the required function block and click OK.
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Step Action

7 After selecting the function block, click OK on the Function Input Assistant screen.

Result: An icon appears near the arrow of the mouse.

8 Left-click on the configuration zone.

Result: The structural view of the function block is displayed on the screen.

For more information on the available functional blocks and its configuration, refer
to the EcoStruxure Control Expert – TeSys island Library Control – User Guide.
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